<!doctype html> <!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-AU"> <![endif]--> <!--[if IE 7]><html class="no-js lt-ie9 lt-ie8" lang="en-AU"> <![endif]--> <!--[if IE 8]><html class="no-js lt-ie9" lang="en-AU"> <![endif]--> <!--[if IE 9]><html class="no-js lt-ie10" lang="en-AU"> <![endif]--> <!--[if gt IE 8]><!--><html class="no-js" lang="en-AU"> <!--<![endif]--><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' /><link  rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.pickr.com.au/xmlrpc.php" /><link rel='dns-prefetch' href='//cdn.pickr.com.au' /><link rel="manifest" href="https://cdn.pickr.com.au/superpwa-manifest.json"><meta name="theme-color" content="#ae2024"><link rel="apple-touch-icon" sizes="192x192" href="https://cdn.pickr.com.au/media/2018/11/pickr-2016-icon-trans-192-high.png"><link rel="apple-touch-icon" sizes="512x512" href="https://cdn.pickr.com.au/media/2016/07/pickr-2016-icon-trans-512.png"><meta name="theme-color" content="#ae2024"><meta name="msapplication-navbutton-color" content="#ae2024"><meta name="apple-mobile-web-app-status-bar-style" content="#ae2024"><title>Acer&#039;s ConceptD workstation notebook returns the Ezel hinge &ndash; Pickr</title><link rel="stylesheet" href="https://cdn.pickr.com.au/wp-content/cache/min/1/49cbff567832b7db132b7131e1fb5d23.css" data-minify="1" /><meta name="description" content="The professional laptop could get more interesting, as Acer returns a design from its history."/><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://www.pickr.com.au/news/2019/acers-conceptd-workstation-notebook-returns-the-ezel-hinge/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Acer&#039;s ConceptD workstation notebook returns the Ezel hinge &ndash; Pickr" /><meta property="og:description" content="The professional laptop could get more interesting, as Acer returns a design from its history." /><meta property="og:url" content="https://www.pickr.com.au/news/2019/acers-conceptd-workstation-notebook-returns-the-ezel-hinge/" /><meta property="og:site_name" content="Pickr" /><meta property="article:publisher" content="https://www.facebook.com/PickrAU/" /><meta property="article:author" content="http://facebook.com/leighlo" /><meta property="article:tag" content="4K" /><meta property="article:tag" content="4K computer" /><meta property="article:tag" content="Acer" /><meta property="article:tag" content="desktop PC" /><meta property="article:tag" content="HDR" /><meta property="article:tag" content="Intel" /><meta property="article:tag" content="Intel Core" /><meta property="article:tag" content="workstation" /><meta property="article:section" content="News" /><meta property="article:published_time" content="2019-11-25T21:06:45+00:00" /><meta property="article:modified_time" content="2019-11-25T19:50:44+00:00" /><meta property="og:updated_time" content="2019-11-25T19:50:44+00:00" /><meta property="og:image" content="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-03.jpg" /><meta property="og:image:secure_url" content="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-03.jpg" /><meta property="og:image:width" content="2000" /><meta property="og:image:height" content="905" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The professional laptop could get more interesting, as Acer returns a design from its history." /><meta name="twitter:title" content="Acer&#039;s ConceptD workstation notebook returns the Ezel hinge &ndash; Pickr" /><meta name="twitter:site" content="@PickrAU" /><meta name="twitter:image" content="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-03.jpg" /><meta name="twitter:creator" content="@leighlo" /> <script  type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.pickr.com.au/#website","url":"https://www.pickr.com.au/","name":"Pickr","potentialAction":{"@type":"SearchAction","target":"https://www.pickr.com.au/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.pickr.com.au/news/2019/acers-conceptd-workstation-notebook-returns-the-ezel-hinge/#primaryimage","url":"https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-03.jpg","width":2000,"height":905,"caption":"Acer ConceptD 9"},{"@type":"WebPage","@id":"https://www.pickr.com.au/news/2019/acers-conceptd-workstation-notebook-returns-the-ezel-hinge/#webpage","url":"https://www.pickr.com.au/news/2019/acers-conceptd-workstation-notebook-returns-the-ezel-hinge/","inLanguage":"en-AU","name":"Acer&#039;s ConceptD workstation notebook returns the Ezel hinge &ndash; Pickr","isPartOf":{"@id":"https://www.pickr.com.au/#website"},"primaryImageOfPage":{"@id":"https://www.pickr.com.au/news/2019/acers-conceptd-workstation-notebook-returns-the-ezel-hinge/#primaryimage"},"datePublished":"2019-11-25T21:06:45+00:00","dateModified":"2019-11-25T19:50:44+00:00","author":{"@id":"https://www.pickr.com.au/#/schema/person/e655807ceb0370daf66fe118f995530b"},"description":"The professional laptop could get more interesting, as Acer returns a design from its history."},{"@type":["Person"],"@id":"https://www.pickr.com.au/#/schema/person/e655807ceb0370daf66fe118f995530b","name":"Leigh :) Stark","image":{"@type":"ImageObject","@id":"https://www.pickr.com.au/#authorlogo","url":"https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=96&d=retro&r=r","caption":"Leigh :) Stark"},"description":"A technology journalist working out of Sydney, Australia, Leigh has written for publications including The Australian Financial Review, GadgetGuy, Popular Science, APC, PC &amp; Tech Authority, as well as for radio and TV since 2007.","sameAs":["http://facebook.com/leighlo","https://www.linkedin.com/in/leighlo?trk=nav_responsive_tab_profile","https://twitter.com/leighlo"]}]}</script> <link rel="amphtml" href="https://www.pickr.com.au/news/2019/acers-conceptd-workstation-notebook-returns-the-ezel-hinge/amp/" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel='dns-prefetch' href='//fonts.gstatic.com' /><link rel='dns-prefetch' href='//adservice.google.com.au' /><link rel='dns-prefetch' href='//www.googletagservices.com' /><link rel='dns-prefetch' href='//cdn.pickr.com.au' /><link rel="alternate" type="application/rss+xml" title="Pickr &raquo; Feed" href="https://www.pickr.com.au/feed/" /> <script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='contact-form-7-inline-css' type='text/css'>.wpcf7 .wpcf7-recaptcha iframe{margin-bottom:0}</style><link  rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Open+Sans%3Aregular%2Citalic%2C600%2C700%2C700italic%2C600%2C600italic%2Cregular%2Citalic&#038;display=swap&#038;ver=1.0.0' type='text/css' media='all' /> <!--[if lt IE 9]><link   rel='stylesheet' id='vc_lte_ie9-css' href='https://cdn.pickr.com.au/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' /> <![endif]--> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <link rel='https://api.w.org/' href='https://www.pickr.com.au/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.pickr.com.au/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.pickr.com.au/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.pickr.com.au/?p=32438' /><meta property="fb:pages" content="1306375316069323" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-7421266024255206",
enable_page_level_ads: true,
});</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/www.pickr.com.au\/#organization","url":"https:\/\/www.pickr.com.au\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/pickrau","https:\/\/www.instagram.com\/pickrau\/","https:\/\/twitter.com\/pickrau","https:\/\/www.linkedin.com\/company\/17899558\/admin\/"]}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/www.pickr.com.au\/#website","url":"https:\/\/www.pickr.com.au\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.pickr.com.au\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel="icon" href="https://cdn.pickr.com.au/wp-content/uploads/2016/07/cropped-pickr-2016-icon-trans-512-32x32.png" sizes="32x32" /><link rel="icon" href="https://cdn.pickr.com.au/wp-content/uploads/2016/07/cropped-pickr-2016-icon-trans-512-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://cdn.pickr.com.au/wp-content/uploads/2016/07/cropped-pickr-2016-icon-trans-512-180x180.png" /><meta name="msapplication-TileImage" content="https://cdn.pickr.com.au/wp-content/uploads/2016/07/cropped-pickr-2016-icon-trans-512-270x270.png" />  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://cdn.pickr.com.au/wp-content/cache/busting/google-tracking/ga-b66b3b5d54e154c81a50880cdcd7e5f8.js','ga');
  ga('create', 'UA-71845768-1', 'auto');
  ga('send', 'pageview');</script> <style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display:none}</style><style type="text/css" id="wp-custom-css">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</style><style type="text/css" data-type="vc_shortcodes-custom-css">.vc_custom_1572174821548{margin-top:-30px!important;margin-bottom:20px!important;padding-top:280px!important;padding-bottom:30px!important}</style><noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body data-rsssl=1 class="post-template-default single single-post postid-32438 single-format-standard wp-embed-responsive jeg_toggle_dark jnews jnews_boxed_container jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"><div class="jeg_ad jeg_ad_top jnews_header_top_ads"><div class='ads-wrapper '></div></div><div class="jeg_viewport"><div class="jeg_header_wrapper"><div class="jeg_header_instagram_wrapper"></div><div class="jeg_header normal"><div class="jeg_midbar jeg_container normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_logo jeg_desktop_logo"><div class="site-title"> <a href="https://www.pickr.com.au/" style="padding: 0 0 0 0;"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-200.png" data-dark-srcset="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-200.png 1x, https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-400.png 2x" data-lazy-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png"><noscript><img class='jeg_logo_img' src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png" srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-200.png" data-dark-srcset="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-200.png 1x, https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-400.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_2" data-animation="animate"><li id="menu-item-31678" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-31678 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/">Latest News &#038; Reviews</a></li><li id="menu-item-25110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25110 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/phones/">Phones</a></li><li id="menu-item-8063" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8063 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/computers/">PC &#038; Mac</a></li><li id="menu-item-15489" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15489 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/sound/">Audio Gear</a></li><li id="menu-item-15490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15490 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/visual/">TV &#038; VR</a></li><li id="menu-item-13224" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13224 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/the-wrap/">The Wrap</a></li></ul></div></div></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"><div class="jeg_separator separator4"></div><div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://www.pickr.com.au/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div></div><div class="jeg_header_sticky"><div class="sticky_blankspace"></div><div class="jeg_header normal"><div class="jeg_container"><div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_logo"><div class="site-title"> <a href="https://www.pickr.com.au/"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-100.png" data-dark-srcset="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-100.png 1x, https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-200.png 2x" data-lazy-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png"><noscript><img class='jeg_logo_img' src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png" srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-100.png" data-dark-srcset="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-100.png 1x, https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-200.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_2" data-animation="animate"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-31678 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/">Latest News &#038; Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25110 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/phones/">Phones</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8063 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/computers/">PC &#038; Mac</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15489 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/sound/">Audio Gear</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15490 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/visual/">TV &#038; VR</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13224 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/the-wrap/">The Wrap</a></li></ul></div></div></div></div></div></div></div></div></div></div><div class="jeg_navbar_mobile_wrapper"><div class="jeg_navbar_mobile" data-mode="scroll"><div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_mobile_logo"><div class="site-title"> <a href="https://www.pickr.com.au/"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-100w-50h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-100w-50h-2018.png" data-light-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-100w-50h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-100.png" data-dark-srcset="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-100.png 1x, https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-200.png 2x" data-lazy-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-100w-50h-2018.png"><noscript><img class='jeg_logo_img' src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-100w-50h-2018.png" srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-100w-50h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-100w-50h-2018.png" data-light-srcset="https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-100w-50h-2018.png 1x, https://cdn.pickr.com.au/media/2019/03/pickr-logo-2016-200w-100h-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-100.png" data-dark-srcset="https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-100.png 1x, https://cdn.pickr.com.au/media/2019/10/pickr-dark-logo-200.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_grow"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_dark_mode"> <label class="dark_mode_switch"> <input type="checkbox" class="jeg_dark_mode_toggle"> <span class="slider round"></span> </label></div><div class="jeg_nav_item"> <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a></div></div></div></div></div></div></div><div class="sticky_blankspace" style="height: 60px;"></div></div><div class="post-wrapper"><div class="post-wrap" ><div class="jeg_main "><div class="jeg_container"><div class="jeg_content"><div class="jeg_vc_content custom_post_template"><p><div data-bg="url(https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-03.jpg)" data-vc-full-width="true" data-vc-full-width-init="false" style="!important;background-repeat: no-repeat !important;background-position: center center !important;background-attachment: scroll !important;background-size: cover !important"" class="row vc_row vc_custom_1572174821548 vc_row-o-content-bottom vc_row-flex jeg_relative rocket-lazyload"><div class="jeg-vc-wrapper"><div class="jeg_row_overlay" style="background-color: rgba(10,10,10,0.42);"></div><div class="transback wpb_column jeg_column vc_column_container vc_col-sm-12 jeg_main_content"><div class="jeg_wrapper wpb_wrapper"><div class='jeg_custom_title_wrapper alt '><h1 class="jeg_post_title">Acer&#8217;s ConceptD workstation notebook returns the Ezel hinge</h1></div><div class='jeg_post_meta jeg_custom_meta_wrapper alt '><div class='meta_left'><div class="jeg_meta_author"><img alt='Leigh :) Stark' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=160&#038;d=retro&#038;r=r 2x' class='avatar avatar-80 photo' height='80' width='80' data-lazy-src="https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=80&#038;d=retro&#038;r=r" /><noscript><img alt='Leigh :) Stark' src='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=80&#038;d=retro&#038;r=r' srcset='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=160&#038;d=retro&#038;r=r 2x' class='avatar avatar-80 photo' height='80' width='80' /></noscript><span class="meta_text">by</span><a href="https://www.pickr.com.au/author/leigh/">Leigh :) Stark</a></div><div class="jeg_meta_date"> <a href="https://www.pickr.com.au/news/2019/acers-conceptd-workstation-notebook-returns-the-ezel-hinge/">November 26, 2019</a></div><div class="jeg_meta_reading_time"> <span> 3 min read </span></div></div><div class='meta_right'></div></div></div></div></div></div><div class="vc_row-full-width vc_clearfix"></div><div class="row vc_row"><div class="jeg-vc-wrapper"><div class="wpb_column jeg_column vc_column_container vc_col-sm-9 jeg_main_content"><div class="jeg_wrapper wpb_wrapper"><div class='jeg_custom_content_wrapper '><div class='entry-content with-share'><div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal"><div class="jeg_share_float_container"><div class="jeg_sharelist"> <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.pickr.com.au%2Fnews%2F2019%2Facers-conceptd-workstation-notebook-returns-the-ezel-hinge%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Acer%E2%80%99s+ConceptD+workstation+notebook+returns+the+Ezel+hinge+via+%40%40PickrAU&url=https%3A%2F%2Fwww.pickr.com.au%2Fnews%2F2019%2Facers-conceptd-workstation-notebook-returns-the-ezel-hinge%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.pickr.com.au%2Fnews%2F2019%2Facers-conceptd-workstation-notebook-returns-the-ezel-hinge%2F&title=Acer%E2%80%99s+ConceptD+workstation+notebook+returns+the+Ezel+hinge" rel='nofollow' class="jeg_btn-linkedin expanded"><i class="fa fa-linkedin"></i><span>Share on LinkedIn</span></a><div class="share-secondary"> <a href="mailto:?subject=Acer%E2%80%99s+ConceptD+workstation+notebook+returns+the+Ezel+hinge&amp;body=https%3A%2F%2Fwww.pickr.com.au%2Fnews%2F2019%2Facers-conceptd-workstation-notebook-returns-the-ezel-hinge%2F" rel='nofollow' class="jeg_btn-email "><i class="fa fa-envelope"></i></a><a href="mailto:?subject=Acer%E2%80%99s+ConceptD+workstation+notebook+returns+the+Ezel+hinge&amp;body=https%3A%2F%2Fwww.pickr.com.au%2Fnews%2F2019%2Facers-conceptd-workstation-notebook-returns-the-ezel-hinge%2F" rel='nofollow' class="jeg_btn-email "><i class="fa fa-envelope"></i></a></div> <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a></div></div></div><div class='content-inner'><p><strong>The professional laptop could get more interesting, as Acer returns a design from its history. </strong></p><p>Depending on just how much computing power you need, you might be looking at a different class of computer. It&#8217;s not about raw power, because if you want that, the custom desktop PC or specialty Mac Pro and iMac Pro can offer that.</p><p>Rather, it can be about form-factor.</p><p>Take if you&#8217;re a creative and want a big screen and powerful graphics processor, you probably need to look at a relatively sizeable 15 or 16 inch computer with a meaty set of specs inside, and possibly some extra bits to make it stand out.</p><p><a href="https://www.pickr.com.au/microsoft-windows/2018/microsoft-surface-book-2/">If you grab a Surface Book</a>, the special features that make it stand out are the fact that it turns into a tablet simply by disconnecting the whole unit, which means it&#8217;s a very thin tablet when you need it to be come one. Another option is <a href="https://www.pickr.com.au/reviews/2017/dell-precision-5520-laptop-20th-anniversary-edition/">Dell&#8217;s workstation-grade Precision range</a>, which are often the high-end XPS range with workstation-focused insides. <a href="https://www.pickr.com.au/news/2019/razor-takes-its-laptops-to-workstation-grade-levels/">Razer even has a workstation-class laptop now</a>, too, so there are clearly options.</p><p>On the other side, if you adopt <a href="https://www.pickr.com.au/news/2019/apple-supersizes-15-inch-mbp-to-16-inch-macbook-pro/">the recently launched MacBook Pro 16</a>, it&#8217;s an almost bezel-less screen, very high-end specs, and the extra macOS features like <a href="https://www.pickr.com.au/reviews/2019/macos-catalina-reviewed-one-of-the-best-updates-yet/">using an iPad as a second screen</a> and the TrueTone display, not to mention six speakers instead of two and four.</p><p>But there are other ways a laptop can stand out, and Acer is attempting to win over creators and creatives with some of them, launching the &#8220;ConceptD&#8221; range in Australia.</p><p><picture><source data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-01-1024x715.jpg.webp 1024w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-01-750x524.jpg.webp 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-01-1140x796.jpg.webp 1140w" sizes="(max-width: 1024px) 100vw, 1024px" type="image/webp"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20715'%3E%3C/svg%3E" alt="Acer ConceptD 9" width="1024" height="715" class="aligncenter size-large wp-image-32437 webpexpress-processed" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-01-1024x715.jpg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-01-750x524.jpg 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-01-1140x796.jpg 1140w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-9-2019-01-1024x715.jpg"></picture></p><p>A little bit different, Acer&#8217;s concept computers are a take on the workstation going in modern directions, be it with features for designers and 3D creators looking for a machine to allow them to do things differently from other PCs.</p><p>At the high end, there&#8217;s the ConceptD 9, a machine that returns Acer&#8217;s old &#8220;Ezel&#8221; hinge from a laptop it once had in 2013, and delivering a whopping 32GB RAM, Intel Core i9 chip, and a GeForce chip made for 3D development and gaming, the RTX2080. Acer says the focus on this one is for 3D work, and includes a 4K Ultra HD screen that has been validated for Pantone colour with 100 percent of the Adobe RGB colour gamut, with support for a Wacom pen included as well. That special Ezel hinge makes it both a tablet on a stand and a laptop, and differs from the usual 360 degree hinge that folds a screen all the way around the laptop.</p><p>The ConceptD 9 isn&#8217;t the only model to arrive, but it is the only one to see the Ezel hinge&#8217;s return.</p><p><picture><source data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-7-2019-02-1024x660.jpg.webp 1024w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-7-2019-02-750x484.jpg.webp 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-7-2019-02-1140x735.jpg.webp 1140w" sizes="(max-width: 1024px) 100vw, 1024px" type="image/webp"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20660'%3E%3C/svg%3E" alt="Acer ConceptD 7" width="1024" height="660" class="aligncenter size-large wp-image-32433 webpexpress-processed" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-7-2019-02-1024x660.jpg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-7-2019-02-750x484.jpg 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-7-2019-02-1140x735.jpg 1140w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-7-2019-02-1024x660.jpg"></picture></p><p>In fact, Acer&#8217;s ConceptD 7 is a laptop that is a little more &#8220;normal&#8221;, slimming the laptop down and including a 4K HD screen, same Pantone and Adobe colour accuracy, and support for either a GeForce RTX or a Quadro workstation-class graphics chip.</p><p>There is a desktop that Acer will be bringing to the mix &#8212; the Acer ConceptD 500 &#8212; basically backing a similar approach to the ConceptD hardware, yet in a smaller desktop made for power without the screen. If you want Acer&#8217;s approach to a screen, two of those are coming in 27 inch ConceptD monitors made with varying amounts of high dynamic range.</p><figure id="attachment_32432" aria-describedby="caption-attachment-32432" style="width: 1024px" class="wp-caption aligncenter"><picture><source data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-cp7-monitor-1024x818.jpg.webp 1024w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-cp7-monitor-750x599.jpg.webp 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-cp7-monitor-1140x910.jpg.webp 1140w" sizes="(max-width: 1024px) 100vw, 1024px" type="image/webp"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20818'%3E%3C/svg%3E" alt="Acer ConceptD CP7" width="1024" height="818" class="size-large wp-image-32432 webpexpress-processed" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-cp7-monitor-1024x818.jpg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-cp7-monitor-750x599.jpg 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-cp7-monitor-1140x910.jpg 1140w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-cp7-monitor-1024x818.jpg"></picture><figcaption id="caption-attachment-32432" class="wp-caption-text">Acer ConceptD CP7 monitor</figcaption></figure><p>&#8220;Bringing ConceptD to Australia is an exciting milestone for Acer as it marks a new chapter in the solutions we deliver to the local market,&#8221; said Darren Simmons, Managing Director for Oceania at Acer.</p><p>&#8220;While Acer continues to innovate and have a strong <a href="https://www.pickr.com.au/news/2019/acer-gives-gamers-options-in-triton-500-900/">presence across gaming</a>, education, commercial and thin-and-light categories, we saw a clear opportunity to expand our offering with a range tailor-made for creators and their unique needs,&#8221; he said.</p><p>&#8220;The creative industries are integral to the economy, having contributed $111.7 billion to Australia in 2016-17 according to the Bureau of Communications and Arts Research (BCAR). As ConceptD devices are equipped with high-performance processors and graphics that can handle extreme workloads, they are designed to enable creators to bring their ideas to life more effectively and further drive these outcomes.&#8221;</p><p>However winning people over on price may end up being a big more difficult for Acer.</p><p>While Acer&#8217;s computers are definitely up there in specs and include interesting designs, they also include hefty prices, too, with one computer, the ConceptD 9 with its Ezel hinge, stretching to the $8999 price tag in Australia. The slimmer ConceptD 7 workstation ranges from $3999 to $6999, still not necessarily inexpensive, while the desktop ranges from $5499 to $7049, and the monitors cost $1899 or $2999. Indeed, it seems Acer&#8217;s ConceptD range isn&#8217;t for creatives who aren&#8217;t afraid of spending up.</p><figure id="attachment_32431" aria-describedby="caption-attachment-32431" style="width: 1024px" class="wp-caption aligncenter"><picture><source data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-500-1024x773.jpg.webp 1024w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-500-750x566.jpg.webp 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-500-1140x860.jpg.webp 1140w" sizes="(max-width: 1024px) 100vw, 1024px" type="image/webp"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20773'%3E%3C/svg%3E" alt="Acer ConceptD 500 desktop" width="1024" height="773" class="size-large wp-image-32431 webpexpress-processed" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-500-1024x773.jpg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-500-750x566.jpg 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-500-1140x860.jpg 1140w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2019/11/acer-concept-d-500-1024x773.jpg"></picture><figcaption id="caption-attachment-32431" class="wp-caption-text">Acer&#8217;s workstation-grade ConceptD 500 is focused on creators with cash.</figcaption></figure></div></div></div><div class='jeg_custom_author_wrapper jnews_author_box_container '><div class="jeg_authorbox"><div class="jeg_author_image"> <img alt='Leigh :) Stark' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=160&#038;d=retro&#038;r=r 2x' class='avatar avatar-80 photo' height='80' width='80' data-lazy-src="https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=80&#038;d=retro&#038;r=r" /><noscript><img alt='Leigh :) Stark' src='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=80&#038;d=retro&#038;r=r' srcset='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=160&#038;d=retro&#038;r=r 2x' class='avatar avatar-80 photo' height='80' width='80' /></noscript></div><div class="jeg_author_content"><h3 class="jeg_author_name"> <a href="https://www.pickr.com.au/author/leigh/"> Leigh :) Stark </a></h3><p class="jeg_author_desc"> A technology journalist working out of Sydney, Australia, Leigh has written for publications including The Australian Financial Review, GadgetGuy, Popular Science, APC, PC &amp; Tech Authority, as well as for radio and TV since 2007.</p><div class="jeg_author_socials"> <a target='_blank' href='http://facebook.com/leighlo' class='facebook'><i class='fa fa-facebook-official'></i> </a><a target='_blank' href='leighlo' class='twitter'><i class='fa fa-twitter'></i> </a><a target='_blank' href='https://www.linkedin.com/in/leighlo?trk=nav_responsive_tab_profile' class='linkedin'><i class='fa fa-linkedin'></i> </a></div></div></div></div><div class='jnews_related_post_container jeg_custom_related_wrapper nocat'><div class="jeg_postblock_22 jeg_postblock jeg_module_hook jeg_pagination_nextprev jeg_col_3o3 jnews_module_32438_6_5ddca14b480f3 " data-unique="jnews_module_32438_6_5ddca14b480f3"><div class="jeg_block_heading jeg_block_heading_4 jeg_subcat_right"><h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3></div><div class="jeg_block_container"><div class="jeg_posts_wrap"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_md_5 post-32255 post type-post status-publish format-standard has-post-thumbnail hentry category-home-entertainment category-news category-online tag-4k tag-disney tag-star-wars tag-streaming-video lh_instant_articles-syndicate-yes"><div class="jeg_thumb"> <a href="https://www.pickr.com.au/news/2019/disney-arrives-in-australia-with-star-wars-in-4k/"><div class="thumbnail-container animate-lazy size-715 "><picture><source data-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-350x250.jpeg.webp 350w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-120x86.jpeg.webp 120w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-750x536.jpeg.webp 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-1140x815.jpeg.webp 1140w" data-sizes="auto" type="image/webp"><img width="350" height="250" src="https://cdn.pickr.com.au/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image webpexpress-processed" alt=""The Mandalorian" in Disney+" data-src="https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-350x250.jpeg" data-sizes="auto" data-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-350x250.jpeg 350w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-120x86.jpeg 120w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-750x536.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/A964D74F-D9A8-481E-9D22-155AC1E9AD9F-1140x815.jpeg 1140w" data-expand="700"></picture></div></a><div class="jeg_post_category"> <span><a href="https://www.pickr.com.au/home-entertainment/" class="category-home-entertainment">Home Entertainment</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://www.pickr.com.au/news/2019/disney-arrives-in-australia-with-star-wars-in-4k/">Disney+ arrives in Australia with Star Wars in 4K</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.pickr.com.au/news/2019/disney-arrives-in-australia-with-star-wars-in-4k/" ><i class="fa fa-clock-o"></i> November 19, 2019</a></div></div></div></article><article class="jeg_post jeg_pl_md_5 post-32251 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-tv category-visual tag-4k tag-4k-tv tag-airplay-2 tag-bo tag-bang-olufsen tag-chromecast tag-lg tag-luxury tag-oled tag-webos lh_instant_articles-syndicate-yes"><div class="jeg_thumb"> <a href="https://www.pickr.com.au/news/2019/bang-olufsen-brings-the-harmony-to-a-smaller-size/"><div class="thumbnail-container animate-lazy size-715 "><picture><source data-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-350x250.jpg.webp 350w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-120x86.jpg.webp 120w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-750x536.jpg.webp 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-1140x815.jpg.webp 1140w" data-sizes="auto" type="image/webp"><img width="350" height="250" src="https://cdn.pickr.com.au/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image webpexpress-processed" alt="B&O Beovision Harmony 65" data-src="https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-350x250.jpg" data-sizes="auto" data-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-350x250.jpg 350w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-120x86.jpg 120w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-750x536.jpg 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/bang-olufsen-beovision-harmony-65-2019-01-1140x815.jpg 1140w" data-expand="700"></picture></div></a><div class="jeg_post_category"> <span><a href="https://www.pickr.com.au/visual/tv/" class="category-tv">TV</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://www.pickr.com.au/news/2019/bang-olufsen-brings-the-harmony-to-a-smaller-size/">Bang &#038; Olufsen brings the Harmony to a smaller size</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.pickr.com.au/news/2019/bang-olufsen-brings-the-harmony-to-a-smaller-size/" ><i class="fa fa-clock-o"></i> November 19, 2019</a></div></div></div></article><article class="jeg_post jeg_pl_md_5 post-32172 post type-post status-publish format-standard has-post-thumbnail hentry category-apple category-computers category-news tag-amd tag-apple tag-intel tag-intel-core tag-macbook-pro tag-macos tag-radeon tag-workstation lh_instant_articles-syndicate-yes"><div class="jeg_thumb"> <a href="https://www.pickr.com.au/news/2019/apple-supersizes-15-inch-mbp-to-16-inch-macbook-pro/"><div class="thumbnail-container animate-lazy size-715 "><picture><source data-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-350x250.jpg.webp 350w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-120x86.jpg.webp 120w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-750x536.jpg.webp 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-1140x815.jpg.webp 1140w" data-sizes="auto" type="image/webp"><img width="350" height="250" src="https://cdn.pickr.com.au/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image webpexpress-processed" alt="Apple 16 inch MacBook Pro" data-src="https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-350x250.jpg" data-sizes="auto" data-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-350x250.jpg 350w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-120x86.jpg 120w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-750x536.jpg 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/macbook-pro-16-2019-01-1140x815.jpg 1140w" data-expand="700"></picture></div></a><div class="jeg_post_category"> <span><a href="https://www.pickr.com.au/apple/" class="category-apple">Apple</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://www.pickr.com.au/news/2019/apple-supersizes-15-inch-mbp-to-16-inch-macbook-pro/">Apple supersizes 15 inch MBP to 16 inch MacBook Pro</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.pickr.com.au/news/2019/apple-supersizes-15-inch-mbp-to-16-inch-macbook-pro/" ><i class="fa fa-clock-o"></i> November 14, 2019</a></div></div></div></article><article class="jeg_post jeg_pl_md_5 post-32044 post type-post status-publish format-standard has-post-thumbnail hentry category-cameras category-news tag-4k tag-4k-camera tag-4k-cameras tag-5k tag-csc tag-leica tag-luxury tag-milc tag-mirrorless tag-water-resistance lh_instant_articles-syndicate-yes"><div class="jeg_thumb"> <a href="https://www.pickr.com.au/news/2019/leicas-sl2-is-a-47-megapixel-metal-mirrorless/"><div class="thumbnail-container animate-lazy size-715 "><picture><source data-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-350x250.jpeg.webp 350w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-120x86.jpeg.webp 120w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-750x536.jpeg.webp 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-1140x815.jpeg.webp 1140w" data-sizes="auto" type="image/webp"><img width="350" height="250" src="https://cdn.pickr.com.au/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image webpexpress-processed" alt="Leica SL2" data-src="https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-350x250.jpeg" data-sizes="auto" data-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-350x250.jpeg 350w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-120x86.jpeg 120w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-750x536.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2019/11/3A34DD35-6D28-4001-924B-C1CCAEDF16C3-1140x815.jpeg 1140w" data-expand="700"></picture></div></a><div class="jeg_post_category"> <span><a href="https://www.pickr.com.au/cameras/" class="category-cameras">Cameras</a></span></div></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://www.pickr.com.au/news/2019/leicas-sl2-is-a-47-megapixel-metal-mirrorless/">Leica&#8217;s SL2 is a 47 megapixel metal mirrorless</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.pickr.com.au/news/2019/leicas-sl2-is-a-47-megapixel-metal-mirrorless/" ><i class="fa fa-clock-o"></i> November 9, 2019</a></div></div></div></article></div></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div><div class="jeg_block_nav "> <a href="#" class="prev disabled" title="Previous"><i class="fa fa-angle-left"></i></a> <a href="#" class="next " title="Next"><i class="fa fa-angle-right"></i></a></div></div> <script >var jnews_module_32438_6_5ddca14b480f3 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_4","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"4","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":32438,"include_category":"","exclude_category":"","include_author":"","include_tag":"288,578,590,586,293,185,320,824","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"nextprev","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":"4","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":"50","paged":1,"column_class":"jeg_col_3o3","class":"jnews_block_22"};</script> </div></div></div></div><div class="wpb_column jeg_column vc_column_container vc_col-sm-3 jeg_sticky_sidebar jeg_sidebar"><div class="jeg_wrapper wpb_wrapper"><div class="wpb_widgetised_column wpb_content_element"><div class="wpb_wrapper"><div class="widget-odd widget-last widget-first widget-1 widget widget_jnews_module_element_ads" id="jnews_module_element_ads-3"><div class='jeg_ad jeg_ad_module jnews_module_32438_7_5ddca14b4e596 '><div class='ads-wrapper'><div class=""><style type='text/css' scoped>.adsslot_aNmZz2B4Xh{width:300px!important;height:600px!important}@media (max-width:1199px){.adsslot_aNmZz2B4Xh{width:300px!important;height:600px!important}}@media (max-width:767px){.adsslot_aNmZz2B4Xh{width:300px!important;height:250px!important}}</style><ins class="adsbygoogle adsslot_aNmZz2B4Xh" style="display:inline-block;" data-ad-client="ca-pub-7421266024255206" data-ad-slot="7175881258"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div><div class='ads-text'>ADVERTISEMENT</div></div></div></div></div></div></div></div></div></div><div class="row vc_row"><div class="jeg-vc-wrapper"><div class="wpb_column jeg_column vc_column_container vc_col-sm-12 jeg_main_content"><div class="jeg_wrapper wpb_wrapper"><div class="wpb_text_column wpb_content_element " ><div class="wpb_wrapper"><p><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_end">﻿</span></p></div></div></div></div></div></div></p><div class="jnews_popup_post_container"></div></div></div></div></div><div id="post-body-class" class="post-template-default single single-post postid-32438 single-format-standard wp-embed-responsive jeg_toggle_dark jnews jnews_boxed_container jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"></div></div><div class="post-ajax-overlay"><div class="preloader_type preloader_dot"><div class="newsfeed_preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="newsfeed_preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="newsfeed_preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="footer-holder" id="footer" data-id="footer"><div class="jeg_footer jeg_footer_4 normal"><div class="jeg_footer_container jeg_container"><div class="jeg_footer_content"><div class="container"><div class="row"><div class="jeg_footer_primary clearfix"><div class="col-md-9 footer_column"><ul class="jeg_menu_footer"><li id="menu-item-1467" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1467"><a href="https://www.pickr.com.au/faq/">Questions (FAQ)</a></li><li id="menu-item-1427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1427"><a href="https://www.pickr.com.au/research/">Research</a></li><li id="menu-item-1494" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1494"><a href="https://www.pickr.com.au/methodology/">Methodology</a></li><li id="menu-item-23729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23729"><a href="https://www.pickr.com.au/awards/">Awards</a></li><li id="menu-item-756" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-756"><a href="https://www.pickr.com.au/contact/">Contact</a></li></ul></div><div class="col-md-3 footer_column footer_right"><div class="footer-text"> <strong> Change the way you choose.</strong></div></div></div><div class="jeg_footer_secondary clearfix"><div class="col-md-9 footer_column"><p class="copyright"> © 2016 to 2019 Publishr Pty Ltd: ACN 624 227 256<br /> All rights reserved.</p></div><div class="col-md-3 footer_column footer_right"><div class="jeg_social_icon_block socials_widget nobg"> <a href="https://www.facebook.com/pickrau" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://www.instagram.com/pickrau/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a><a href="https://twitter.com/pickrau" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.linkedin.com/company/17899558/admin/" target='_blank' class="jeg_linkedin"><i class="fa fa-linkedin"></i> </a></div></div></div></div></div></div></div></div></div><div class="jscroll-to-top"> <a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a></div></div><div id="jeg_off_canvas" class="normal"> <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a><div class="jeg_bg_overlay"></div><div class="jeg_mobile_wrapper"><div class="nav_wrap"><div class="item_main"><div class="jeg_aside_item"><ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-31678"><a href="https://www.pickr.com.au/">Latest News &#038; Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25110"><a href="https://www.pickr.com.au/phones/">Phones</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8063"><a href="https://www.pickr.com.au/computers/">PC &#038; Mac</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15489"><a href="https://www.pickr.com.au/sound/">Audio Gear</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15490"><a href="https://www.pickr.com.au/visual/">TV &#038; VR</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13224"><a href="https://www.pickr.com.au/the-wrap/">The Wrap</a></li></ul></div><div class="jeg_aside_item socials_widget nobg"> <a href="https://www.facebook.com/pickrau" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://www.instagram.com/pickrau/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a><a href="https://twitter.com/pickrau" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.linkedin.com/company/17899558/admin/" target='_blank' class="jeg_linkedin"><i class="fa fa-linkedin"></i> </a></div></div><div class="item_bottom"><div class="jeg_aside_item jeg_aside_copyright"><p>© 2016 to 2019 Publishr Pty Ltd: ACN 624 227 256<br /> All rights reserved.</p></div></div></div></div></div><div class="jeg_read_progress_wrapper"></div> <script type='text/javascript'>/* <![CDATA[ */ var lrJS = {"root":"https:\/\/www.pickr.com.au\/wp-json\/codetipi-lets-review\/v3\/","nonce":"14cb2b7bb2","i18n":{"alreadyVoted":"Change Your Rating"},"letsReviewAUrl":"https:\/\/www.pickr.com.au\/wp-admin\/admin-ajax.php","letsReviewNonce":"4dc3657418","letsReviewUReviews":"0"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var superpwa_sw = {"url":"\/superpwa-sw.js"}; /* ]]> */</script> <!--[if lt IE 9]> <script  type='text/javascript' src='https://cdn.pickr.com.au/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=5.2.2'></script> <![endif]--><div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Acer&#8217;s ConceptD workstation notebook returns the Ezel hinge","published":"2019-11-26 08:06:45","updated":"2019-11-25 19:50:44"}</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://cdn.pickr.com.au/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script><script src="https://cdn.pickr.com.au/wp-content/cache/min/1/1f7b138b02575fbdc189f28d9833ee9d.js" data-minify="1" defer></script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1574740299 -->