<!doctype html> <!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-AU"> <![endif]--> <!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-AU"> <![endif]--> <!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-AU"> <![endif]--> <!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-AU"> <![endif]--> <!--[if gt IE 8]><!--> <html class="no-js" lang="en-AU"> <!--<![endif]--><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.pickr.com.au/xmlrpc.php" /><link rel="manifest" href="https://cdn.pickr.com.au/superpwa-manifest.json"><meta name="theme-color" content="#ae2024"><link rel="apple-touch-icon" sizes="192x192" href="https://www.pickr.com.au/media/2018/11/pickr-2016-icon-trans-192-high.png"><link rel="apple-touch-icon" sizes="512x512" href="https://www.pickr.com.au/media/2016/07/pickr-2016-icon-trans-512.png"><meta name="theme-color" content="#ae2024"><meta name="msapplication-navbutton-color" content="#ae2024"><meta name="apple-mobile-web-app-status-bar-style" content="#ae2024"> <script type="text/javascript">var jnews_ajax_url = '/?ajax-request=jnews'</script> <title>Review: Jabra Evolve2 65 Stereo wireless headphones &ndash; Pickr</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A600%2C600italic%2C700%2C700italic%2Citalic%2Cregular&#038;display=swap" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://cdn.pickr.com.au/wp-content/cache/min/1/963d716c70a2f28aaca73e04a44003cd.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="Not sure if your headphones are doing your WFH lifestyle justice? The Jabra Evolve2 65 might just deliver a more professional take." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Review: Jabra Evolve2 65 Stereo wireless headphones &ndash; Pickr" /><meta property="og:description" content="Not sure if your headphones are doing your WFH lifestyle justice? The Jabra Evolve2 65 might just deliver a more professional take." /><meta property="og:url" content="https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/" /><meta property="og:site_name" content="Pickr" /><meta property="article:publisher" content="https://www.facebook.com/PickrAU/" /><meta property="article:author" content="http://facebook.com/leighlo" /><meta property="article:published_time" content="2020-08-25T06:38:05+00:00" /><meta property="article:modified_time" content="2020-08-25T06:41:39+00:00" /><meta property="og:image" content="https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1.jpeg" /><meta property="og:image:width" content="2000" /><meta property="og:image:height" content="1233" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@leighlo" /><meta name="twitter:site" content="@PickrAU" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.pickr.com.au/#website","url":"https://www.pickr.com.au/","name":"Pickr","description":"Australian technology news, reviews, and guides to help you","potentialAction":[{"@type":"SearchAction","target":"https://www.pickr.com.au/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-AU"},{"@type":"ImageObject","@id":"https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/#primaryimage","inLanguage":"en-AU","url":"https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1.jpeg","width":2000,"height":1233,"caption":"Jabra Evolve2 65 headset reviewed"},{"@type":"WebPage","@id":"https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/#webpage","url":"https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/","name":"Review: Jabra Evolve2 65 Stereo wireless headphones &ndash; Pickr","isPartOf":{"@id":"https://www.pickr.com.au/#website"},"primaryImageOfPage":{"@id":"https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/#primaryimage"},"datePublished":"2020-08-25T06:38:05+00:00","dateModified":"2020-08-25T06:41:39+00:00","author":{"@id":"https://www.pickr.com.au/#/schema/person/e655807ceb0370daf66fe118f995530b"},"description":"Not sure if your headphones are doing your WFH lifestyle justice? The Jabra Evolve2 65 might just deliver a more professional take.","inLanguage":"en-AU","potentialAction":[{"@type":"ReadAction","target":["https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/"]}]},{"@type":["Person"],"@id":"https://www.pickr.com.au/#/schema/person/e655807ceb0370daf66fe118f995530b","name":"Leigh :) Stark","image":{"@type":"ImageObject","@id":"https://www.pickr.com.au/#personlogo","inLanguage":"en-AU","url":"https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=96&d=retro&r=r","caption":"Leigh :) Stark"},"description":"A technology journalist working out of Sydney, Australia, Leigh has written for publications including The Australian Financial Review, GadgetGuy, Popular Science, APC, PC &amp; Tech Authority, as well as for radio and TV since 2007.","sameAs":["http://facebook.com/leighlo","https://www.linkedin.com/in/leighlo?trk=nav_responsive_tab_profile","https://twitter.com/leighlo"]}]}</script> <link rel="amphtml" href="https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/amp/" /><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel='dns-prefetch' href='//fonts.gstatic.com' /><link rel='dns-prefetch' href='//adservice.google.com.au' /><link rel='dns-prefetch' href='//adservice.google.com' /><link rel='dns-prefetch' href='//www.googletagservices.com' /><link rel='dns-prefetch' href='//cdn.pickr.com.au' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Pickr &raquo; Feed" href="https://www.pickr.com.au/feed/" /> <script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style> <script id="wpacu-preload-async-css-fallback">/*! LoadCSS. [c]2017 Filament Group, Inc. MIT License */
    /* This file is meant as a standalone workflow for
	- testing support for link[rel=preload]
	- enabling async CSS loading in browsers that do not support rel=preload
	- applying rel preload css once loaded, whether supported or not.
	*/
    !function(n){"use strict";n.wpacuLoadCSS||(n.wpacuLoadCSS=function(){});var o=wpacuLoadCSS.relpreload={};if(o.support=function(){var e;try{e=n.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),o.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},o.poly=function(){if(!o.support())for(var t=n.document.getElementsByTagName("link"),e=0;e<t.length;e++){var a=t[e];"preload"!==a.rel||"style"!==a.getAttribute("as")||a.getAttribute("data-wpacuLoadCSS")||(a.setAttribute("data-wpacuLoadCSS",!0),o.bindMediaToggle(a))}},!o.support()){o.poly();var t=n.setInterval(o.poly,500);n.addEventListener?n.addEventListener("load",function(){o.poly(),n.clearInterval(t)}):n.attachEvent&&n.attachEvent("onload",function(){o.poly(),n.clearInterval(t)})}"undefined"!=typeof exports?exports.wpacuLoadCSS=wpacuLoadCSS:n.wpacuLoadCSS=wpacuLoadCSS}("undefined"!=typeof global?global:this);</script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var icwp_wpsf_vars_lpantibot = {"form_selectors":"","uniq":"5f44b2af8c197","cbname":"icwp-wpsf-58c7883f236e0","strings":{"label":"I'm a human.","alert":"Please check the box to show us you're a human.","loading":"Loading"},"flags":{"gasp":true,"captcha":false}}; /* ]]> */</script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/plugins/wp-simple-firewall/resources/js/shield-antibot-0848c689cabafd17f103fbcf19a738e1.js' defer></script> <script data-no-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/busting/1/gtm-3bbe435cb3c4701bd9ceba85169db8dd.js' defer></script> <script   type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-71845768-1', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://www.pickr.com.au/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.pickr.com.au/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.pickr.com.au/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.pickr.com.au/?p=37855' /><meta property="fb:pages" content="1306375316069323" /><link rel="preload" as="font" href="https://cdn.pickr.com.au/wp-content/themes/jnews/assets/fonts/font-awesome/fonts/fontawesome-webfont.woff2?v=4.7.0" crossorigin><link rel="preload" as="font" href="https://cdn.pickr.com.au/wp-content/themes/jnews/assets/fonts/jegicon/fonts/jegicon.woff" crossorigin> <script data-ad-client="ca-pub-7421266024255206" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/www.pickr.com.au\/#organization","url":"https:\/\/www.pickr.com.au\/","name":"Pickr.com.au","logo":{"@type":"ImageObject","url":"https:\/\/www.pickr.com.au\/wp-content\/uploads\/2019\/12\/pickr-xmas-black-point5x.png"},"sameAs":["https:\/\/www.facebook.com\/pickrau","https:\/\/www.instagram.com\/pickrau\/","https:\/\/twitter.com\/pickrau","https:\/\/www.linkedin.com\/company\/17899558\/admin\/"]}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/www.pickr.com.au\/#website","url":"https:\/\/www.pickr.com.au\/","name":"Pickr.com.au","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.pickr.com.au\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel="icon" href="https://cdn.pickr.com.au/wp-content/uploads/2016/07/cropped-pickr-2016-icon-trans-512-32x32.png" sizes="32x32" /><link rel="icon" href="https://cdn.pickr.com.au/wp-content/uploads/2016/07/cropped-pickr-2016-icon-trans-512-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://cdn.pickr.com.au/wp-content/uploads/2016/07/cropped-pickr-2016-icon-trans-512-180x180.png" /><meta name="msapplication-TileImage" content="https://cdn.pickr.com.au/wp-content/uploads/2016/07/cropped-pickr-2016-icon-trans-512-270x270.png" /><style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail .jeg_thumb,.thumbnail-container.no_thumbnail{display:none!important}.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,.jeg_pl_sm.no_thumbnail .jeg_postblock_content{margin-left:0}.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content{margin-top:0}.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content{position:relative}.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa{color:#212121!important}</style><style type="text/css" id="wp-custom-css">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</style><style type="text/css" data-type="vc_shortcodes-custom-css">.vc_custom_1572174821548{margin-top:-30px!important;margin-bottom:20px!important;padding-top:280px!important;padding-bottom:30px!important}</style><noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body data-rsssl=1 class="post-template-default single single-post postid-37855 single-format-standard wp-embed-responsive jeg_toggle_dark jnews jnews_boxed_container jsc_normal wpb-js-composer js-comp-ver-6.2.0 vc_responsive"><div class="jeg_ad jeg_ad_top jnews_header_top_ads"><div class='ads-wrapper '></div></div><div class="jeg_viewport"><div class="jeg_header_wrapper"><div class="jeg_header_instagram_wrapper"></div><div class="jeg_header normal"><div class="jeg_midbar jeg_container normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_logo jeg_desktop_logo"><div class="site-title"> <a href="https://www.pickr.com.au/" style="padding: 0 0 0 0;"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png" data-dark-srcset="https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-400.png 2x" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png"><noscript><img class='jeg_logo_img' src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png" data-dark-srcset="https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-400.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_2" data-animation="animate"><li id="menu-item-31678" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-31678 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/">Latest News &#038; Reviews</a></li><li id="menu-item-37854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37854 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/recommended/">Recommended</a></li><li id="menu-item-25110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25110 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/phones/">Phones</a></li><li id="menu-item-8063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8063 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/computers/">PC &#038; Mac</a></li><li id="menu-item-15489" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15489 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/sound/">Sound</a></li><li id="menu-item-34975" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-34975 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/tag/4k/">4K</a></li><li id="menu-item-34994" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-34994 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/tag/8k/">8K</a></li><li id="menu-item-13224" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13224 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/the-wrap/">The Wrap</a></li></ul></div></div></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"><div class="jeg_separator separator4"></div><div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://www.pickr.com.au/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div></div><div class="jeg_header_sticky"><div class="sticky_blankspace"></div><div class="jeg_header normal"><div class="jeg_container"><div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_logo"><div class="site-title"> <a href="https://www.pickr.com.au/"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png" data-dark-srcset="https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-400.png 2x" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png"><noscript><img class='jeg_logo_img' src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png" data-dark-srcset="https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-400.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_2" data-animation="animate"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-31678 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/">Latest News &#038; Reviews</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37854 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/recommended/">Recommended</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25110 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/phones/">Phones</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8063 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/computers/">PC &#038; Mac</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15489 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/sound/">Sound</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-34975 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/tag/4k/">4K</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-34994 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/tag/8k/">8K</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13224 bgnav" data-item-row="default" ><a href="https://www.pickr.com.au/the-wrap/">The Wrap</a></li></ul></div></div></div></div></div></div></div></div></div></div><div class="jeg_navbar_mobile_wrapper"><div class="jeg_navbar_mobile" data-mode="scroll"><div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_mobile_logo"><div class="site-title"> <a href="https://www.pickr.com.au/"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png" data-dark-srcset="https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-400.png 2x" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png"><noscript><img class='jeg_logo_img' src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" srcset="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" alt="Pickr"data-light-src="https://cdn.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png" data-light-srcset="https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-200w-100h-2018.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/03/pickr-logo-2016-400w-2018.png 2x" data-dark-src="https://cdn.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png" data-dark-srcset="https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-200.png 1x, https://www.pickr.com.au/wp-content/uploads/2019/10/pickr-dark-logo-400.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_grow"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_dark_mode"> <label class="dark_mode_switch"> <input type="checkbox" class="jeg_dark_mode_toggle"> <span class="slider round"></span> </label></div><div class="jeg_nav_item"> <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a></div></div></div></div></div></div></div><div class="sticky_blankspace" style="height: 60px;"></div></div><div class="post-wrapper"><div class="post-wrap" ><div class="jeg_main "><div class="jeg_container"><div class="jeg_content"><div class="jeg_vc_content custom_post_template"><p><div data-bg="https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1.jpeg" data-vc-full-width="true" data-vc-full-width-init="false" style="!important;background-repeat: no-repeat !important;background-position: center center !important;background-attachment: scroll !important;background-size: cover !important"" class="row vc_row wpb_row vc_row-fluid vc_custom_1572174821548 vc_row-o-content-bottom vc_row-flex jeg_relative rocket-lazyload"><div class="jeg-vc-wrapper"><div class="jeg_row_overlay" style="background-color: rgba(10,10,10,0.42);"></div><div class="transback wpb_column jeg_column vc_column_container vc_col-sm-12 jeg_main_content"><div class="jeg_wrapper wpb_wrapper"><div class='jeg_custom_title_wrapper alt '><h1 class="jeg_post_title">Jabra Evolve2 65 wireless headphones reviewed</h1></div><div class='jeg_post_meta jeg_custom_meta_wrapper alt '><div class='meta_left'><div class="jeg_meta_author"><img alt='Leigh :) Stark' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=160&#038;d=retro&#038;r=r 2x' class='avatar avatar-80 photo' height='80' width='80' data-lazy-src="https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=80&#038;d=retro&#038;r=r" /><noscript><img alt='Leigh :) Stark' src='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=80&#038;d=retro&#038;r=r' srcset='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=160&#038;d=retro&#038;r=r 2x' class='avatar avatar-80 photo' height='80' width='80' /></noscript><span class="meta_text">by</span><a href="https://www.pickr.com.au/author/leigh/">Leigh :) Stark</a></div><div class="jeg_meta_date"> <a href="https://www.pickr.com.au/reviews/2020/jabra-evolve2-65-stereo-office-wireless-headphones/">August 25, 2020</a></div><div class="jeg_meta_reading_time"> <span> 8 min read </span></div></div><div class='meta_right'></div></div></div></div></div></div><div class="vc_row-full-width vc_clearfix"></div><div class="row vc_row wpb_row vc_row-fluid"><div class="jeg-vc-wrapper"><div class="wpb_column jeg_column vc_column_container vc_col-sm-9 jeg_main_content"><div class="jeg_wrapper wpb_wrapper"><div class='jeg_custom_content_wrapper '><div class='entry-content with-share'><div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome"><div class="jeg_share_float_container"><div class="jeg_sharelist"> <a href="https://twitter.com/intent/tweet?text=Jabra+Evolve2+65+wireless+headphones+reviewed+via+%40%40PickrAU&url=https%3A%2F%2Fwww.pickr.com.au%2Freviews%2F2020%2Fjabra-evolve2-65-stereo-office-wireless-headphones%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.pickr.com.au%2Freviews%2F2020%2Fjabra-evolve2-65-stereo-office-wireless-headphones%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.pickr.com.au%2Freviews%2F2020%2Fjabra-evolve2-65-stereo-office-wireless-headphones%2F&title=Jabra+Evolve2+65+wireless+headphones+reviewed" rel='nofollow' class="jeg_btn-linkedin expanded"><i class="fa fa-linkedin"></i><span>Share on LinkedIn</span></a><a href="mailto:?subject=Jabra+Evolve2+65+wireless+headphones+reviewed&amp;body=https%3A%2F%2Fwww.pickr.com.au%2Freviews%2F2020%2Fjabra-evolve2-65-stereo-office-wireless-headphones%2F" rel='nofollow' class="jeg_btn-email expanded"><i class="fa fa-envelope"></i><span>Share over email</span></a></div></div></div><div class='content-inner'><p><strong>Not sure if the headphones you own are doing your work-from-home lifestyle justice? You might want to check out something skewed to the office, if we ever go back.</strong></p><h2>Design and features</h2><p>Headphones come in all shapes and sizes, and some are clearly larger than others. You only really need to look at the bulk of noise cancelling headphones to find what constitutes &#8220;large&#8221; these days, though some headphones are a little on the lighter side.</p><p>A first glance at the Jabra Evolve2 65 shows that&#8217;s where we are with this pair, with an on-ear design for headphones and a leatherette padding that covers the entire surface area for where your ears will sit. It&#8217;s a follow-up to the first Evolve 65, a call-centre style set of headphones with a long boom mic that looked more like it belonged in a call-centre and nowhere else.</p><p><a href="https://www.pickr.com.au/news/2020/jabra-launches-business-noise-cancelling-for-the-office-caller/">The Jabra Evolve2 65 headphones are a little bit different</a>, and follow more of the consumer headphone focus for Jabra, this time <a href="https://www.jabra.com.au/bluetooth-headsets/jabra-elite-45h" target="_blank" rel="noopener noreferrer">the Elite 45h, which are a dead ringer</a> if not for the obvious inclusion of a boom mic. Like the 45h, you&#8217;ll find metal and plastic come together for this design, which make the headphones a little more like something you&#8217;d want to wear out and about, especially in comparison to other working headphones.</p><p><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA.jpeg"><img class="aligncenter size-full wp-image-37864" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201204'%3E%3C/svg%3E" alt="Jabra Evolve2 65 headset" width="2000" height="1204" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA-1024x616.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA-1536x925.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA-750x452.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA-1140x686.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA.jpeg" /><noscript><img class="aligncenter size-full wp-image-37864" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA.jpeg" alt="Jabra Evolve2 65 headset" width="2000" height="1204" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA-1024x616.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA-1536x925.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA-750x452.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/A51184A3-DBE1-4CA0-80C4-D8F2A56280CA-1140x686.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a></p><p>Jabra has provided connectivity support for both the Bluetooth in your phone and computer, as well as a secondary USB key with Bluetooth, in case you don&#8217;t trust the USB in your computer or you want to make sure it stays link to a specific wireless dongle regardless of which computer you connect to.</p><p>Outside of the connectivity options, which are Bluetooth and can handle two devices, the Evolve2 65 on-headphones come 40mm drivers, a battery good for as much as 35 hours of talk time or 37 hours of music, and a light to let people know if you&#8217;re busy.</p><p>They may even come with a stand to charge the headphones up &#8212; ours did &#8212; though there&#8217;s also a Type C USB port on the bottom of the headphones.</p><p><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E.jpeg"><img class="aligncenter size-full wp-image-37869" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201330'%3E%3C/svg%3E" alt="The Evolve2 65 in its cradle" width="2000" height="1330" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E-1024x681.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E-1536x1021.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E-750x499.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E-1140x758.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E.jpeg" /><noscript><img class="aligncenter size-full wp-image-37869" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E.jpeg" alt="The Evolve2 65 in its cradle" width="2000" height="1330" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E-1024x681.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E-1536x1021.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E-750x499.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/77456C7F-33A3-45C3-8F55-BC82C1807C8E-1140x758.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a></p><h2>In-use</h2><p>Throw the headphones on and you&#8217;ll find controls at the top, and that&#8217;s about it. While some of Jabra&#8217;s other earphones feel a little more logical in terms of how you&#8217;ll pause, play, and raise and lower volume, Jabra has gone with something almost deliberately old school, with three buttons for volume up, pause and play, and volume down.</p><p>There&#8217;s no extra texture on the pause or play, which dents the ease of use these headphones could have, either. The main button is marginally larger, though you&#8217;ll never notice it at the fingertips, only if you&#8217;re looking at the headphones.</p><p>Sadly, it&#8217;s not quite the same tactile approach to design <a href="https://www.pickr.com.au/reviews/2019/jabra-elite-85h-wireless-anc-headphones/">Jabra showed in the 85h</a>, and you&#8217;ll probably want to rely on that device of yours, be it the controls when you&#8217;re connected to your computer, or that phone you love and adore so much.</p><p><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B.jpeg"><img class="aligncenter size-full wp-image-37870" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201274'%3E%3C/svg%3E" alt="Controls on the Jabra Evolve2 65" width="2000" height="1274" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B-1024x652.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B-1536x978.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B-750x478.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B-1140x726.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B.jpeg" /><noscript><img class="aligncenter size-full wp-image-37870" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B.jpeg" alt="Controls on the Jabra Evolve2 65" width="2000" height="1274" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B-1024x652.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B-1536x978.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B-750x478.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/E27EE6DF-2C85-456B-B317-411E124CF03B-1140x726.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a></p><h2>Sound performance</h2><p>Move past the controls and you can sail on through to the sound, and that&#8217;s an area Jabra has been getting right fairly consistently for a number of years now.</p><p>Jabra has long catered for a fairly balanced approach to audio, and that&#8217;s pretty much what you get here, with no real distractions in a specific style, be it bright, warm, or bassy-as.</p><p>Testing with <a href="https://www.pickr.com.au/methodology/sound-test/">the Pickr Sound Test</a>, we found electronic through Tycho and Daft Punk handled the highs and mids nicely, with just enough delivery in the bottom end to be comfortable, while tracks with more pronounced bass, such as in Charlie Puth&#8217;s &#8220;Done For Me&#8221; offered a fairly tight snap to the sounds.</p><p>Even in FKA Twigs&#8217; &#8220;Two Weeks&#8221;, the bass response is more than acceptable, with a rendition that isn&#8217;t ear shattering, but instead a more than comfortable end that some headphones would be envious of.</p><p><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA.jpeg"><img class="aligncenter size-full wp-image-37874" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201266'%3E%3C/svg%3E" alt="Wearing the Jabra Evolve2 65 wireless headphones" width="2000" height="1266" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA-1024x648.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA-1536x972.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA-750x475.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA-1140x722.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA.jpeg" /><noscript><img class="aligncenter size-full wp-image-37874" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA.jpeg" alt="Wearing the Jabra Evolve2 65 wireless headphones" width="2000" height="1266" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA-1024x648.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA-1536x972.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA-750x475.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4794E837-A375-4B11-BC88-86F587D74FAA-1140x722.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a></p><p>Over in rock, we found the balance continued, with solid sound reproduction in Rage Against the Machine, David Bowie, and The Beatles, while classical and jazz were relaxed but fairly even.</p><p>While the Jabra Evolve2 65 aren&#8217;t clearly focused on listening to music, they handle music quite well, which should delight folks reliant on them for keeping them entertained and comfortable as they work.</p><p>But that&#8217;s also a major point: the Jabra Evolve range of headsets may work like headphones, but they&#8217;re primarily headsets, and so requires another round of testing, not just for music.</p><h2>Headset performance</h2><p><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456.jpeg"><img class="aligncenter size-full wp-image-37873" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201161'%3E%3C/svg%3E" alt="Wearing the Jabra Evolve2 65 wireless headphones" width="2000" height="1161" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456-1024x594.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456-1536x892.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456-750x435.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456-1140x662.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456.jpeg" /><noscript><img class="aligncenter size-full wp-image-37873" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456.jpeg" alt="Wearing the Jabra Evolve2 65 wireless headphones" width="2000" height="1161" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456-1024x594.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456-1536x892.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456-750x435.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/F6DCF2E5-A1DB-454B-81B3-B60E0E5B9456-1140x662.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a></p><p>A little different is the headset performance, which is distinct from the headphone performance simply because the Jabra Evolve2 65 isn&#8217;t just another pair of headphones made for your computer to listen to music, but rather to talk to people on, as well.</p><p>We&#8217;re in that work from home age, the &#8220;WFH&#8221; initialism we all bandy about, and that means we may need more than a standard mic on our computer or headphones to make sure we&#8217;re heard clearly.</p><p>To that end, the Evolve2 65 uses a boom arm on the right side, which can be pushed up to steer clear from your hands when not in use. Built more for Microsoft Teams use, complete with a push button to light up a purple light for Teams to tell people you&#8217;re busy, the mic arm can&#8217;t be relocated to the other side, meaning if you&#8217;re someone who prefers the mic on the left side, too bad.</p> <!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]--> <audio class="wp-audio-shortcode" id="audio-37855-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/Mic-Test-At-Desk-Jabra-Evolve2-65.mp3?_=1" /><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/Mic-Test-At-Desk-Jabra-Evolve2-65.mp3">https://www.pickr.com.au/wp-content/uploads/2020/08/Mic-Test-At-Desk-Jabra-Evolve2-65.mp3</a></audio><p>&nbsp;</p><p>The sound out of the microphone is definitely decent and certainly clear enough for a Zoom, though the Jabra boom arm can&#8217;t really hold a candle to a larger cardioid microphone like the sort we use for <a href="https://www.pickr.com.au/the-wrap">the podcast, The Wrap</a>. They&#8217;re not really in the same category, though, so we wouldn&#8217;t expect it.</p><p>As far as microphone sound goes, though, the Jabra&#8217;s Evolve2 65 is a compact approach to quality sound, married with a great quality set of headphones, making them ideal for work and play.</p><p><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F.jpeg"><img class="aligncenter size-full wp-image-37866" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201230'%3E%3C/svg%3E" alt="The microphone on the Jabra Evolve2 65 headset" width="2000" height="1230" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F-1024x630.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F-1536x945.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F-750x461.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F-1140x701.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F.jpeg" /><noscript><img class="aligncenter size-full wp-image-37866" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F.jpeg" alt="The microphone on the Jabra Evolve2 65 headset" width="2000" height="1230" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F-1024x630.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F-1536x945.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F-750x461.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/038A93E9-C034-4C9C-8CC2-DDC0D4666E5F-1140x701.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a></p><h2>Battery</h2><p>And play is important, because while you can leave the Evolve2 65 at your desk, you don&#8217;t really have to. Supporting Bluetooth Multipoint with up to two devices at a time, they&#8217;re a pair of headphones you might want to take out and about with you, which means battery life is a thing that clearly matters.</p><p>While you might be tethered to your desk for work, you don&#8217;t need to leave the headphones next to your mouse or laptop, because these can go out and about, too, working with your phone as that second device, and delivering up to 37 hours, as it is.</p><p>Those 37 hours are contingent upon you not using the purple &#8220;do not disturb&#8221; light, though, which will reduce the time a little if left on. Switch it off when you have no one around you, because clearly, it won&#8217;t matter.</p><p>Recharging the Evolve2 65 is easy-as, also, because you&#8217;re given two ways to make it happen: either the USB Type C port on the bottom side (which is the way we opted for), or the charging cradle, which can take a little bit of aiming to get right. Including a cradle is a nice option, and it can also tidy up your desk, too.</p><h2>Value</h2><p><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A.jpeg"><img class="aligncenter size-full wp-image-37867" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201208'%3E%3C/svg%3E" alt="Jabra Evolve2 65 wireless headphones reviewed" width="2000" height="1208" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A-1024x618.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A-1536x928.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A-750x453.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A-1140x689.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A.jpeg" /><noscript><img class="aligncenter size-full wp-image-37867" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A.jpeg" alt="Jabra Evolve2 65 wireless headphones reviewed" width="2000" height="1208" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A-1024x618.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A-1536x928.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A-750x453.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4519BD0E-A1BE-435F-A1D5-0C3C399AD48A-1140x689.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a></p><p>At $437, though, the Jabra Evolve2 65 may not feel like the best deal, thanks to what it&#8217;s been built for: business.</p><p>Typically, headphones $400 and higher start to include noise cancellation, a feature that is missing in action here. Essentially, the Evolve2 65 are boom mic-equipped versions of the Jabra Elite 45h, but with a little extra functionality for folks who need Microsoft Teams. With the Elite 45h retailing for $179 locally, the Evolve2 65 are asking an extra $250 or so for the extra functionality, something office-style headsets are known to ask for. You can typically expect a higher cost if headphones are focused on work, and the Jabra Evolve2 65 are no different in this respect.</p><p>That said, the price isn&#8217;t bad for what you get, and while noise cancellation would be nice, the sound is crisp and fairly balanced, and the support for a USB plug in Type C is also handy, though you may be able to pick the standard Type A plug if you prefer.</p><p><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0.jpeg"><img class="aligncenter size-full wp-image-37868" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201254'%3E%3C/svg%3E" alt="The Jabra 370 USB Type C Bluetooth adaptor" width="2000" height="1254" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0-1024x642.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0-1536x963.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0-750x470.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0-1140x715.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0.jpeg" /><noscript><img class="aligncenter size-full wp-image-37868" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0.jpeg" alt="The Jabra 370 USB Type C Bluetooth adaptor" width="2000" height="1254" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0-1024x642.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0-1536x963.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0-750x470.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/4E715BF4-B467-4EAF-AA7F-DDEF4BDF6BA0-1140x715.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a></p><h2>What needs work?</h2><p>While the Jabra Evolve2 65 is a decent headset for talking at work, there are definitely things we&#8217;d do and add. Noise cancellation, for instance, because while we&#8217;re working from home now, on transport and in the office, a little bit of noise cancellation would go a long way for this style of headset.</p><p>The inability to remove the mic and change positions is also a touch annoying, though it&#8217;s perhaps more annoying that you can&#8217;t just switch ears on the headphones. Do the stereo switcheroo and wear the left ear on your right to bring that right-side microphone to your left side, and you&#8217;ll quickly find you can&#8217;t actually push the boom mic into position around your lips.</p><p>It&#8217;s minor, sure, but some will prefer the mic on their left. The Jabra Evolve2 65 are just completely and utterly inflexible in this way.</p><figure id="attachment_37872" aria-describedby="caption-attachment-37872" style="width: 2000px" class="wp-caption aligncenter"><a href="https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8.jpeg"><img class="size-full wp-image-37872" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%202000%201312'%3E%3C/svg%3E" alt="Wearing the Jabra Evolve2 65 wireless headphones" width="2000" height="1312" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8-1024x672.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8-1536x1008.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8-750x492.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8-1140x748.jpeg 1140w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8.jpeg" /><noscript><img class="size-full wp-image-37872" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8.jpeg" alt="Wearing the Jabra Evolve2 65 wireless headphones" width="2000" height="1312" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8.jpeg 2000w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8-1024x672.jpeg 1024w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8-1536x1008.jpeg 1536w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8-750x492.jpeg 750w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/1890D9CE-BA40-4134-9B87-7BE0E6D570A8-1140x748.jpeg 1140w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></a><figcaption id="caption-attachment-37872" class="wp-caption-text">One side for the mic, and no way to fix it.</figcaption></figure><h2>Final thoughts (TLDR)</h2><p>If you need a pair of headphones more made for Microsoft Teams, plus the other assortment of meetings you&#8217;re attending with regularity &#8212; the Zoom, WebEx, BlueJeans, and Google Meets the WFH world is thrusting upon us all &#8212; the Jabra Evolve2 65 feels like a decent pair to jump into that won&#8217;t break the bank too much, even if the value feels a touch off.</p><p>At this price point, the Evolve2 65 could do with some form of noise cancellation, particularly since they&#8217;re made to be taken to go and used normally, not just on the desk. But if you don&#8217;t mind living without, they&#8217;re a more than decent pair for the desk bound.</p><div class="lets-review-block__wrap lets-review-block__wrap-10 lr-cf lets-review-wrap-37855 lets-review--center lets-review-skin-1 lets-review-design-1 lets-review-ani-1 lets-review-score-type-3 lets-review-score-type__icon conclusion__off" data-design="1" data-score-type="3" data-skin="1"><div class="lets-review-block lets-review-block__main-title lr-vc lets-review-block__pad" style="background-color: #cc0408"><div class="lets-review-block__mask lr-vc"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="Jabra Evolve2 65 headset reviewed" data-lazy-srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-150x150.jpeg 150w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-350x350.jpeg 350w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-1104x1104.jpeg 1104w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-912x912.jpeg 912w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-550x550.jpeg 550w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-470x470.jpeg 470w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-75x75.jpeg 75w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-150x150.jpeg" /><noscript><img width="150" height="150" src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-150x150.jpeg" class="attachment-thumbnail size-thumbnail" alt="Jabra Evolve2 65 headset reviewed" srcset="https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-150x150.jpeg 150w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-350x350.jpeg 350w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-1104x1104.jpeg 1104w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-912x912.jpeg 912w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-550x550.jpeg 550w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-470x470.jpeg 470w, https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1-75x75.jpeg 75w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></div><div class="lets-review-block__title lr-font-h" style="">Jabra Evolve2 65 Stereo wireless headphones</div></div><div class="lets-review-block lets-review-block__crits lets-review-unseen"><div class="lets-review-block__crit" data-score="80" data-crit="0"><div class="lets-review-block__crit__title lr-font-h" style="">Design</div><div class="score-overlay-wrap score-overlay-wrap__icon" style="color: #cc0408;"><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><div class="score-overlay" style="width:20%"></div></div></div><div class="lets-review-block__crit" data-score="86" data-crit="1"><div class="lets-review-block__crit__title lr-font-h" style="">Performance</div><div class="score-overlay-wrap score-overlay-wrap__icon" style="color: #cc0408;"><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><div class="score-overlay" style="width:14%"></div></div></div><div class="lets-review-block__crit" data-score="70" data-crit="2"><div class="lets-review-block__crit__title lr-font-h" style="">Ease of use</div><div class="score-overlay-wrap score-overlay-wrap__icon" style="color: #cc0408;"><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><div class="score-overlay" style="width:30%"></div></div></div><div class="lets-review-block__crit" data-score="90" data-crit="3"><div class="lets-review-block__crit__title lr-font-h" style="">Battery</div><div class="score-overlay-wrap score-overlay-wrap__icon" style="color: #cc0408;"><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><div class="score-overlay" style="width:10%"></div></div></div><div class="lets-review-block__crit" data-score="60" data-crit="4"><div class="lets-review-block__crit__title lr-font-h" style="">Value</div><div class="score-overlay-wrap score-overlay-wrap__icon" style="color: #cc0408;"><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><div class="score-overlay" style="width:40%"></div></div></div></div><div class="lets-review-block lets-review-block__proscons lets-review-block__pad"><div class="lets-review-block__pros"><div class="proscons__title lets-review-block__title lr-font-h" style="">The good</div><div class="lets-review-block__procon lets-review-block__pro">Comfortable headphones</div><div class="lets-review-block__procon lets-review-block__pro">Fairly strong sound rendition</div><div class="lets-review-block__procon lets-review-block__pro">Comes with a USB dongle (in Type C, no less!)</div><div class="lets-review-block__procon lets-review-block__pro">May come with a charging stand (which is handy)</div></div><div class="lets-review-block__cons"><div class="proscons__title lets-review-block__title lr-font-h" style="">The not-so-good</div><div class="lets-review-block__procon lets-review-block__con">No noise cancellation</div><div class="lets-review-block__procon lets-review-block__con">Microphone has to be on the right side and can't be removed</div><div class="lets-review-block__procon lets-review-block__con">You can't flip the microphone, either (sorry lefties)</div><div class="lets-review-block__procon lets-review-block__con">Expensive</div></div></div><div class="lets-review-block lets-review-block__final-score lets-review-block__final-score-type-3 lets-review-block__pad score-level-8"><div class="score__wrap lr-all-c" style="background:#cc0408; color: #fff"><div class="score-overlay-wrap score-overlay-wrap__icon"><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><i class="fas fa-star"></i><div class="score-overlay" style="width:20%"></div></div><div class="score">4</div></div></div></div><script type="application/ld+json">{"@context": "http://schema.org/",
			"@type": "Organization",
			"name": "Jabra Evolve2 65 Stereo wireless headphones","image": [
				"https://cdn.pickr.com.au/wp-content/uploads/2020/08/78E85796-A6A3-477B-93FD-606F69F887E1.jpeg"
			],"review": {
				"@type": "Review",
				"reviewRating": {
					"@type": "Rating",
					"worstRating": "0",
					"ratingValue": "4",
					"bestRating": "5"
				},
				"author": {
					"@type": "Person",
					"name": "Leigh :) Stark"
				}
			}}</script> </div></div></div><div class='jeg_custom_author_wrapper jnews_author_box_container '><div class="jeg_authorbox"><div class="jeg_author_image"> <img alt='Leigh :) Stark' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=160&#038;d=retro&#038;r=r 2x' class='avatar avatar-80 photo' height='80' width='80' data-lazy-src="https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=80&#038;d=retro&#038;r=r" /><noscript><img alt='Leigh :) Stark' src='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=80&#038;d=retro&#038;r=r' srcset='https://secure.gravatar.com/avatar/4a2540c5bfc0c7784682c42214608649?s=160&#038;d=retro&#038;r=r 2x' class='avatar avatar-80 photo' height='80' width='80' /></noscript></div><div class="jeg_author_content"><h3 class="jeg_author_name"> <a href="https://www.pickr.com.au/author/leigh/"> Leigh :) Stark </a></h3><p class="jeg_author_desc"> A technology journalist working out of Sydney, Australia, Leigh has written for publications including The Australian Financial Review, GadgetGuy, Popular Science, APC, PC &amp; Tech Authority, as well as for radio and TV since 2007.</p><div class="jeg_author_socials"> <a target='_blank' href='http://facebook.com/leighlo' class='facebook'><i class='fa fa-facebook-official'></i> </a> <a target='_blank' href='http://leighlo' class='twitter'><i class='fa fa-twitter'></i> </a> <a target='_blank' href='https://www.linkedin.com/in/leighlo?trk=nav_responsive_tab_profile' class='linkedin'><i class='fa fa-linkedin'></i> </a></div></div></div></div><div class='jnews_related_post_container jeg_custom_related_wrapper nocat'><div class="jeg_postblock_24 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_3o3 jnews_module_37855_6_5f44b2afac17f " data-unique="jnews_module_37855_6_5f44b2afac17f"><div class="jeg_block_heading jeg_block_heading_4 jeg_subcat_right"><h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3></div><div class="jeg_block_container"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_md_box format-standard"><div class="box_wrap"><div class="jeg_thumb"> <a href="https://www.pickr.com.au/news/2020/sony-joins-canon-nikon-by-turning-cameras-into-webcams/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="" data-src="https://cdn.pickr.com.au/wp-content/uploads/2020/05/sony-zv1-video-blog-camera-2020-10-350x250.jpg" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://www.pickr.com.au/news/2020/sony-joins-canon-nikon-by-turning-cameras-into-webcams/">Sony joins Canon, Nikon by turning cameras into webcams</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.pickr.com.au/news/2020/sony-joins-canon-nikon-by-turning-cameras-into-webcams/" ><i class="fa fa-clock-o"></i> August 21, 2020</a></div></div></div></div></article><article class="jeg_post jeg_pl_md_box format-standard"><div class="box_wrap"><div class="jeg_thumb"> <a href="https://www.pickr.com.au/news/2020/asus-slims-down-soups-up-14-inch-2020-zenbook/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Asus slims down, soups up 14 inch 2020 ZenBook" data-src="https://cdn.pickr.com.au/wp-content/uploads/2020/08/asus-zenbook-14-ux425-2020-03-350x250.jpg" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://www.pickr.com.au/news/2020/asus-slims-down-soups-up-14-inch-2020-zenbook/">Asus slims down, soups up 14 inch 2020 ZenBook</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.pickr.com.au/news/2020/asus-slims-down-soups-up-14-inch-2020-zenbook/" ><i class="fa fa-clock-o"></i> August 14, 2020</a></div></div></div></div></article><article class="jeg_post jeg_pl_md_box format-standard"><div class="box_wrap"><div class="jeg_thumb"> <a href="https://www.pickr.com.au/news/2020/sony-bolsters-stills-video-capabilities-in-a7s-iii/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="lazyload wp-post-image" alt="Sony bolsters stills, video capabilities in A7s III" data-src="https://cdn.pickr.com.au/wp-content/uploads/2020/07/sony-a7s-3-2020-06-350x250.jpg" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://www.pickr.com.au/news/2020/sony-bolsters-stills-video-capabilities-in-a7s-iii/">Sony bolsters stills, video capabilities in A7s III</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.pickr.com.au/news/2020/sony-bolsters-stills-video-capabilities-in-a7s-iii/" ><i class="fa fa-clock-o"></i> July 29, 2020</a></div></div></div></div></article></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div></div> <script>var jnews_module_37855_6_5f44b2afac17f = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_4","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":37855,"include_category":"","exclude_category":"","include_author":"","include_tag":"813,1479,177,1417","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"3","pagination_scroll_limit":3,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":"50","paged":1,"column_class":"jeg_col_3o3","class":"jnews_block_24"};</script> </div></div></div></div><div class="wpb_column jeg_column vc_column_container vc_col-sm-3 jeg_sticky_sidebar jeg_sidebar"><div class="jeg_wrapper wpb_wrapper"><div class="wpb_widgetised_column wpb_content_element"><div class="wpb_wrapper"><div class="widget-odd widget-last widget-first widget-1 widget widget_jnews_module_element_ads" id="jnews_module_element_ads-3"><div class='jeg_ad jeg_ad_module jnews_module_37855_7_5f44b2afb0d60 '><div class='ads-wrapper'><div class=""><style type='text/css' scoped>.adsslot_xFYLcvQwUe{width:300px!important;height:600px!important}@media (max-width:1199px){.adsslot_xFYLcvQwUe{width:300px!important;height:600px!important}}@media (max-width:767px){.adsslot_xFYLcvQwUe{width:300px!important;height:250px!important}}</style><ins class="adsbygoogle adsslot_xFYLcvQwUe" style="display:inline-block;" data-ad-client="ca-pub-7421266024255206" data-ad-slot="7175881258"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div><div class='ads-text'>ADVERTISEMENT</div></div></div></div></div></div></div></div></div></div><div class="row vc_row wpb_row vc_row-fluid"><div class="jeg-vc-wrapper"><div class="wpb_column jeg_column vc_column_container vc_col-sm-12 jeg_main_content"><div class="jeg_wrapper wpb_wrapper"><div class="wpb_text_column wpb_content_element " ><div class="wpb_wrapper"></div></div></div></div></div></div></p><div class="jnews_popup_post_container"></div></div></div></div></div><div id="post-body-class" class="post-template-default single single-post postid-37855 single-format-standard wp-embed-responsive jeg_toggle_dark jnews jnews_boxed_container jsc_normal wpb-js-composer js-comp-ver-6.2.0 vc_responsive"></div></div><div class="post-ajax-overlay"><div class="preloader_type preloader_dot"><div class="newsfeed_preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="newsfeed_preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="newsfeed_preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="footer-holder" id="footer" data-id="footer"><div class="jeg_footer jeg_footer_4 normal"><div class="jeg_footer_container jeg_container"><div class="jeg_footer_content"><div class="container"><div class="row"><div class="jeg_footer_primary clearfix"><div class="col-md-9 footer_column"><ul class="jeg_menu_footer"><li id="menu-item-36457" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36457"><a href="https://www.pickr.com.au/recommended/">Recommendations</a></li><li id="menu-item-33114" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33114"><a href="https://www.pickr.com.au/best-picks/">Best Picks</a></li><li id="menu-item-1494" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1494"><a href="https://www.pickr.com.au/methodology/">Methodology</a></li><li id="menu-item-32849" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32849"><a href="https://www.pickr.com.au/about/">About</a></li><li id="menu-item-756" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-756"><a href="https://www.pickr.com.au/contact/">Contact</a></li></ul></div><div class="col-md-3 footer_column footer_right"><div class="footer-text"> <strong> Change the way you choose.</strong></div></div></div><div class="jeg_footer_secondary clearfix"><div class="col-md-9 footer_column"><p class="copyright"> © 2016 to 2020 Publishr Pty Ltd: ACN 624 227 256<br /> All rights reserved.</p></div><div class="col-md-3 footer_column footer_right"><div class="jeg_social_icon_block socials_widget nobg"> <a href="https://www.facebook.com/pickrau" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://www.instagram.com/pickrau/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a><a href="https://twitter.com/pickrau" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.linkedin.com/company/17899558/admin/" target='_blank' class="jeg_linkedin"><i class="fa fa-linkedin"></i> </a></div></div></div></div></div></div></div></div></div><div class="jscroll-to-top"> <a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a></div></div><div id="jeg_off_canvas" class="normal"> <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a><div class="jeg_bg_overlay"></div><div class="jeg_mobile_wrapper"><div class="nav_wrap"><div class="item_main"><div class="jeg_aside_item"><ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-31678"><a href="https://www.pickr.com.au/">Latest News &#038; Reviews</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37854"><a href="https://www.pickr.com.au/recommended/">Recommended</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25110"><a href="https://www.pickr.com.au/phones/">Phones</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8063"><a href="https://www.pickr.com.au/computers/">PC &#038; Mac</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15489"><a href="https://www.pickr.com.au/sound/">Sound</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-34975"><a href="https://www.pickr.com.au/tag/4k/">4K</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-34994"><a href="https://www.pickr.com.au/tag/8k/">8K</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13224"><a href="https://www.pickr.com.au/the-wrap/">The Wrap</a></li></ul></div><div class="jeg_aside_item socials_widget nobg"> <a href="https://www.facebook.com/pickrau" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://www.instagram.com/pickrau/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a><a href="https://twitter.com/pickrau" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.linkedin.com/company/17899558/admin/" target='_blank' class="jeg_linkedin"><i class="fa fa-linkedin"></i> </a></div></div><div class="item_bottom"><div class="jeg_aside_item jeg_aside_copyright"><p>© 2016 to 2020 Publishr Pty Ltd: ACN 624 227 256<br /> All rights reserved.</p></div></div></div></div></div><script type="text/javascript">var jfla = []</script> <script>var tidioScript = document.createElement("script");tidioScript.src = "//code.tidio.co/3sdg4kxih7bkhyrkxyfy5on8wharbhcf.js";
setTimeout(function() {document.body.appendChild(tidioScript)}, 7000);</script> <div class="jeg_read_progress_wrapper"></div><script  type="text/html" id="wpb-modifications"></script><script  type='text/javascript' src='https://cdn.pickr.com.au/wp-content/plugins/lets-review/assets/js/obs.min.js?ver=1.0.0' defer></script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/plugins/lets-review/assets/js/cookie.min.js?ver=2.1.3' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var lrJS = {"root":"https:\/\/www.pickr.com.au\/wp-json\/codetipi-lets-review\/v3\/","nonce":"0e9ee7460d","i18n":{"alreadyVoted":"Change Your Rating"},"letsReviewAUrl":"https:\/\/www.pickr.com.au\/wp-admin\/admin-ajax.php","letsReviewNonce":"46bff102b4","letsReviewUReviews":"0"}; /* ]]> */</script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/plugins/lets-review/assets/js/functions.min.js?ver=3.0.4' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var superpwa_sw = {"url":"\/superpwa-sw.js"}; /* ]]> */</script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/plugins/super-progressive-web-apps/public/js/register-sw-2fffe84d090bc6c4de858c98d5b8f149.js' defer></script> <script   type='text/javascript'>var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.13-9993131' defer></script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.4.2' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"}; /* ]]> */</script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.4.2' defer></script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-includes/js/hoverIntent.min.js?ver=1.8.1' defer></script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-includes/js/imagesloaded.min.js?ver=3.2.0' defer></script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/plugins/js_composer/assets/lib/bower/isotope/dist/isotope.pkgd.min.js?ver=6.2.0' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/lazysizes-7d324509925a65cb5c7cc818da8c0091.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/ls.bgset-aab3a6d2c159ab1e60b2be7053e9c55f.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/owl-carousel2/owl.carousel-7afede3f5bb64023d67b8fa486b6938b.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/superfish-95fb25a6943fa052267155a8f53dd3bb.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/theia-sticky-sidebar-4f837aba01ccba2357e4956f772361c4.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.waypoints-15fbf45733a9c2c68ef1160ceb3fe03e.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.scrollTo-f2cf30625d8ecaf689b41edc1bf19482.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.parallax-5ca6ba23e13ba76b6547a35e3dced881.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.okayNav-f9680ca371f9688c12d8393bad4b7b3a.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.mousewheel-a7defe443c3a985e082711bd27631b4f.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/modernizr-custom-04f67f945807e074f619ef5b0028ddfd.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.smartresize-ff3325896e17dfd17a2d60a54f3e8339.js' defer></script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/plugins/scripts-n-styles/vendor/chosen/chosen.jquery.min.js?ver=1.0.0' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.magnific-popup-98b5242bcab902dfcc96045d796df04f.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.jnewsgif-58489fc0ac76eb8ec415352276bfd13e.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.jowlslider-ed3436b92eea12e8c0573d5a12da2fa3.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.jsticky-e10dc66632ff29d4a74afc42ef8e33c5.js' defer></script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/themes/jnews/assets/js/jquery.transit.min.js?ver=7.0.1' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.module-f57853b91afe29b63d5d0978fab65244.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_AU","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"37855","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"www.pickr.com.au"}; /* ]]> */</script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/main-60df2aae65329401f6f77a6b1c7023db.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/zoom-button-7f7fcc44ddb537b50f3a7c6d0e8ae9d2.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/popup-post-9250d940e059adef97d801e1c2881d09.js' defer></script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/darkmode-239e31a3139eed98dee1fb7d0a0d963e.js' defer></script> <!--[if lt IE 9]>
<script data-wpacu-script-handle='html5shiv' type='text/javascript' src='https://www.pickr.com.au/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=7.0.1'></script>
<![endif]--> <script type='text/javascript'>/* <![CDATA[ */ var jnews_select_share = {"is_customize_preview":""}; /* ]]> */</script> <script data-minify="1"   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/cache/min/1/wp-content/plugins/jnews-social-share/assets/js/plugin-855518d2f88ec0854d5be0373b884115.js' defer></script> <script   type='text/javascript' src='https://cdn.pickr.com.au/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=6.2.0' defer></script> <div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Jabra Evolve2 65 wireless headphones reviewed","published":"2020-08-25 16:38:05","updated":"2020-08-25 06:41:39"}</script> <noscript></noscript> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://cdn.pickr.com.au/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>const wprRemoveCPCSS = () => { if( document.querySelector("link[data-rocket-async='style'][rel='preload']") ){ setTimeout(wprRemoveCPCSS, 200); }else{ $elem = document.getElementById( "rocket-critical-css" );if ( $elem ) {$elem.remove();} } }; if ( window.addEventListener ) { window.addEventListener( "load", wprRemoveCPCSS ); } else if ( window.attachEvent ) { window.attachEvent( "onload", wprRemoveCPCSS ); }</script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A600%2C600italic%2C700%2C700italic%2Citalic%2Cregular&#038;display=swap" /><link rel="stylesheet" href="https://cdn.pickr.com.au/wp-content/cache/min/1/963d716c70a2f28aaca73e04a44003cd.css" data-minify="1" /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1598337711 -->